Verificare le dipendenze di un pacchetto .deb

Per verificare le dipendenze di un qualsiasi pacchetto (*.deb) vi è un apposito comando: apt-rdepends. Se già non lo avete installato installatelo al volo con:
# install apt-rdepends
Se volete imparare ad usarlo basta un

$ man apt-rdepends


Ed infine testiamolo su un pacchetto già installato sulla nostra distro debian-like:

$ apt-rdepends vim

che ci sputa fuori le dipendenze da soddisfare per installare Vim:
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso
Lettura informazioni sullo stato... Fatto
vim
Dipende: libacl1 (>= 2.2.11-1)
Dipende: libc6 (>= 2.7-1)
Dipende: libgpm2 (>= 1.20.4)
Dipende: libncurses5 (>= 5.6+20071006-3)
Dipende: libselinux1 (>= 2.0.59)
Dipende: vim-common (= 2:7.2.000-2)
Dipende: vim-runtime (= 2:7.2.000-2)
libacl1
Dipende: libattr1 (>= 2.4.41-1)
Dipende: libc6 (>= 2.7-1)
libattr1
Dipende: libc6 (>= 2.7-1)
libc6
Dipende: libgcc1
libgcc1
Dipende: gcc-4.3-base (= 4.3.2-1)
Dipende: libc6 (>= 2.7-1)
gcc-4.3-base
libgpm2
Dipende: libc6 (>= 2.7-1)
libncurses5
Dipende: libc6 (>= 2.7-1)
libselinux1
Dipende: libc6 (>= 2.7-1)
vim-common
Dipende: libc6 (>= 2.7-1)
vim-runtime
Dipende: dpkg (>= 1.14.20)
dpkg
Predipende: coreutils (>= 5.93-1)
Predipende: libc6 (>= 2.7-1)
Predipende: lzma
coreutils
Predipende: libacl1 (>= 2.2.11-1)
Predipende: libc6 (>= 2.7-1)
Predipende: libselinux1 (>= 2.0.59)
lzma
Dipende: libc6 (>= 2.7-1)
Dipende: libgcc1 (>= 1:4.1.1)
Dipende: libstdc++6 (>= 4.2.1)
libstdc++6
Dipende: gcc-4.3-base (= 4.3.2-1)
Dipende: libc6 (>= 2.7-1)
Dipende: libgcc1 (>= 1:4.1.1)

tags Tags: ,
categorieCategorie: Linux, Software

Forge Of Empires Italia

Comments are closed.